www.leniwiec.org

Ostatnio w moim życiu zaistniała potrzeba zaopatrzenia się w internet mobilny, a jako że zdobyłem z odzysku BlueConnecta z modemem Huawei E173, postanowiłem podzielić się z wami moimi spostrzeżeniami na temat instalacji tego cuda w ubuntu (lub jakimkolwiek innym linuxie).

Po przerobieniu niemalże wszystkich dostępnych w sieci „instrukcji”, oczywiście żadna z nich nie doprowadziła do sukcesu. ;-) Znalazłem… sterowniki dla linuxa dla tego modelu, wydane przez firmę Movistar (hiszpański telecom), które działają w sposób automagiczny…
Jedyne co jest potrzebne, aby uruchomić ten modem, to paczka zip, która jest dostępna na dole artykułu.
Po jej ściągnięciu i rozpakowaniu, należy nadać znajdującemu się w nim plikowi `install` prawa do wykonywania, można to zrobić z konsoli (chmod +x install) lub z poziomu managera okien, we właściwościach pliku. Po tym wystarczy go uruchomić.
Automatycznie skompiluje się i zainstaluje sterownik dla jądra oraz program Movistar.
Po tej operacji dobrze jest zrestartować komputer. Następnie, gdy włożymy modem w gniazdo USB, automatycznie zostanie uruchomiony program Movistar, który wygląda jak poniżej.

Movistar Main screen

Movistar Main screen

Domyślnie interfejs jest po hiszpańsku, można go zmienić na angielski, wybierając z menu kolejno „Herramientas -> Idioma -> English”. Później już wystarczy tylko dodać nowy profil w Tools->options->Profile Management, dla sieci Era (blueconnect), będzie to wyglądać jak poniżej.

Profile Management

Profile Management

Po czym zatwierdzamy wszystko przyciskiem OK i wybieramy na głównym ekranie ‘Connect’. To wszystko! 5 min i mamy działającego blue connecta w linuxie :-)

16 KOMENTARZY
Darek
6 wrzesień 2011
ad

Bardzo przydatny materiał skorzystałem z zamieszczonych powyżej rad i huawei E173 z Playa śmiga w Ubuntu 10.04 jak ta lala – dzięki

Krzys
3 listopad 2011
ad

W Ubuntu 11.10 wystarczy włożyć modem poczekać chwilkę. Pod ikonką sieci pojawi się dodatkowa pozycja „Sieć komórkowa” wystarczy zaptaszkować i już mamy internet. Ja korzystam z Play i działa wyśmienicie.

leniwiec
3 listopad 2011
ad

Dobrze wiedzieć. Moje próby były jednak czynione na ostatniej wersji LTS, i tam niestety to było jedyne rozwiązanie.

Anonimowy
19 listopad 2011
ad

Mam Backtracka i mi nie działa.
Instaluje się normalnie, ale po włożeniu modemu nic się nie dzieje.

leniwiec
19 listopad 2011
ad

Podaj więcej szczegółów to może coś poradzimy ;)

Artur
25 grudzień 2011
ad

Witam.Dziękuję bardzo autorowi tekstu oraz ludziom którzy pomagają w ten sposób.Uruchomiłem z płyty ubuntu 10.04 LTS 64bit i według wskazówki zadziałało ale po instalacji systemu na dyski jest lipa!Dodam ze zainstalowałem na jednej partycji bez swapu bo mam 8GB ramu ale może być to wina ze system nie ma oddzielnej?Mam inne partycje i tam trzymam dane i win7 na innej.

Damian
1 styczeń 2012
ad

Witam.
Mam problem z otwatciem pliku instal w konsoli ponieważ trzeba go uruchomić z poziomu „root” i szczerze nie mogę sobie z tym poradzić…

leniwiec
1 styczeń 2012
ad

Damian: wpisujesz w konsoli sudo

tomek
24 styczeń 2012
ad

OK – połaczyłem sie w końcu na 10.04 dzięki wielkie, ale
Czy mozna tak ustawić aby sie łaczył automatycnzie i zapamiętał PiN, nie wiem dlaczego przeglądark idziałaja a Pidgin nie :(

Maciej
23 luty 2012
ad

Wszystko prawie zadziałało. Najpierw się trochę męczyłem, żeby odblokować użytkownika root, potem się zainstalowało. Ale działa tylko dla root, a dla zwykłego użytkownika niby się łączy, a nie działa. Mógłbym używać tylko konta root, ale wymyśliłem sobie, że będę używał przeglądarki chrome, która się instaluje, ale nie chce z kolei działać w koncie root. Można oszaleć…

Wojtek
9 marzec 2012
ad

Na 10.04 dziala, dziekuje za to ze nawet taki laik jak ja sobie poradzil :) pozadrawiam

Mariusz
12 czerwiec 2012
ad

na ubuntu 11.04 nie mogę zainstalować wyskakuje coś takiego:
Installing version: 21.003.25.00.211

The software is exist. Do you want overwrite it? ([Y]/N):y

Local path is: /usr/local/Movistar_3.5G

Installing Movistar 3.5G…chmod: nie ma dostępu do `/usr/local/Movistar_3.5G/config’: Nie ma takiego pliku ani katalogu
chmod: nie ma dostępu do `./driver/*’: Nie ma takiego pliku ani katalogu
./install: line 420: ./driver/install: Nie ma takiego pliku ani katalogu
chmod: nie ma dostępu do `./sbin/*’: Nie ma takiego pliku ani katalogu
chmod: nie ma dostępu do `./hw_pppd’: Nie ma takiego pliku ani katalogu
chmod: nie ma dostępu do `./hw_pppd’: Nie ma takiego pliku ani katalogu
cp: nie można wykonać stat na `./hw_pppd’: Nie ma takiego pliku ani katalogu
cp: nie można wykonać stat na `/usr/local/Movistar_3.5G/qtlib/lib*.so*’: Nie ma takiego pliku ani katalogu
cp: nie można wykonać stat na `/usr/local/Movistar_3.5G/sbin/67hw_hook’: Nie ma takiego pliku ani katalogu
chmod: nie ma dostępu do `/etc/pm/sleep.d/67hw_hook’: Nie ma takiego pliku ani katalogu
[ done ]

Finished, press any key to exit

katalog /usr/local/Moviestar_3.5G robi i są tam jakieś pliki
polecenia wykonywałem z gnomecommander jako root i nic z tego proszę o pomoc

Marcin
23 sierpień 2012
ad

Super. Dobrze i konkretnie. Dziękuję autorowi. zrobiłem jak było napisane i pięknie śmiga. Jestem bardzo zadowolony i wdzięczny. Więcej takich.

jabol
21 październik 2012
ad

wygląda uderzająco podobnie do „mobile partner” na winshita firmowanego przez producenta tego modemu. ;)

Waldi
9 luty 2016
ad

Zawsze coś. I weź zrezygnuj z windy. :(

Waldi
9 luty 2016
ad

nic się nie instaluje

Wyślij